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1 General 

This document describes the use of Bachmann macros with EPLAN Electric P8 for
the M1 controller hardware, visualization hardware and PLC data export.
A good knowledge of EPLAN Electric P8 and PLC navigation is required to use the
macros. The file structures mentioned below are for information only and can devi-
ate from the actual structures of the application.

Independent changes to the macros provided by Bachmann electronic GmbH are
not recommended.

Requirements

• EPLAN Electric P8 version 2.1 or higher

• Microsoft Excel® 2003 or higher
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1.1 Importing Bachmann macros from the EPLAN Data Portal 

Macros of the PLC modules are useful for creating a schematic project with Bach-
mann electronic GmbH products. The macros are created by Bachmann electronic
GmbH and are published by EPLAN on the EPLAN Data Portal. From there they
can be imported directly into the schematic project.

Requirements

• Valid EPLAN license

• User account present

• Internet access

General
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Procedure:

1.

Select Utilities > Data Portal Navigator via the menu bar.
è The "Navigator" will open.
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Fig. 1: Navigator

2. From the Navigator, Bachmann articles can be imported directly into the
EPLAN Electric P8 project or can be downloaded as an article to the user's
article database.

General
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1.2 Importing the filter scheme 

To perform a PLC data export to a Bachmann M1 controller, an appropriate filter
scheme must first be imported or created in EPLAN Electric P8.

Requirements

The PLC Navigator (Project data > PLC > Navigator) is opened.

Procedure:

1. Click on  in the PLC Navigator.
è The "Filter" dialog opens.

Fig. 2: "Filter" dialog

2. Click on .
è The "Select import file" dialog opens.

3. Select the directory, from which a scheme should be imported.
4. Highlight the PCfiP.PLC_Addressing_Filter file and click on <Open>.
5. Confirm with <OK>.
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1.3 Importing the export scheme 

To perform a PLC data export to a Bachmann M1 controller or to perform the
addressing externally, an appropriate export scheme must be imported in
EPLAN Electric P8.

Requirements

The "Edit functions externally" dialog (Utilities > Edit properties externally >
Export functions) is opened.

Procedure:

1. Click on  beside the drop-down list Scheme in the "Edit functions exter-
nally" dialog.
è The "Settings: External editing" dialog opens.

2. Click on .
è The "Select import file" dialog opens.

3. Select the directory, from which a scheme should be imported.
4. Import the SolutionCenter export scheme or the PLC adressing scheme.

4.1

Highlight the PCfiP.PLC_Addressing_Schema file and click on
<Open>.

4.2 For File type select type Excel file (*.xls).
4.3 Select the path to the target file via  beside Target file.
4.4 Select the Template_PLC_Addressing_de_en.xls file at Template via

.
5. Confirm with <OK>.

General
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1.4 Importing the PLC addressing scheme 

The absolute addressing of the hardware modules of Bachmann electronic GmbH
is considerably different to the widely used byte-oriented addressing. We therefore
recommend that you create or import a specially adapted addressing scheme.

Procedure:

1. Select Options > Settings > 'Project' > Devices > PLC.
è The "Settings: PLC" dialog opens.

2. Click on  beside the drop-down list Scheme in the "PLC" dialog.
è The "Settings: PLC specific" dialog opens.

Fig. 3: "Settings: PLC specific" dialog

3. Click on .
è The "Select import file" dialog opens.

4. Select the directory, from which a scheme should be imported.
5. Highlight the PP.Bachmann_M1.xml file and click on <Open>.
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2 Drawing with Bachmann macros 

The following should be noted when drawing with Bachmann macros:

• Overview macros ("overview" version) contain all the connections of a device.

• Overview macros with variant E are graphic representations of devices
framed with a PLC box. The PLC box is used for the automatic generation of
PLC configurations in EPLAN Electric P8.

• Rack macros ("multi-line" version) are graphic representations of devices
framed in a PLC box which include the universal supply unit connections of
modules as well. The supply unit connections can also be designed with stand-
ard PLC symbols. Apart from a few exceptions, other variants of the "multi-line"
version contain multi-line connection macros with which a channel can be
placed with all connections using the function Place macro > Multi-line. Only
when there are several active connections per channel must the connections
be assigned individually via Assign.

• Mounting macros (part placement, "control cabinet layout" version) are full-
size 2D graphic representations, which can be used for the placement of parts
when creating the control cabinet layout. If a device has multiple mounting var-
iants, it is possible to find these among different part placement variants.

• If a macro contains several display modes or several variants, those can be
selected via shortcuts. If the macro is attached to the cursor, the [Shift] + [Tab]
keys can be used for switching between the display modes. If a display mode
has several variants, the [Tab] key can be used for switching between them.

• Connections like module supply connections, bus connections, I/O supply
connections and PLC inputs and outputs are configured, if possible, according
to their function:

• With differential inputs (analog modules), the positive input is defined as
PLC connection point, AI.

• For modules with selectable PLC connections, the connections are preallo-
cated according to the function definition, e.g. for the DIO2xx. The preallo-
cation can be modified as needed.

• For modules with 2 connections per channel, one of both preallocated con-
nections is deactivated, e.g. for the AIO288. The preallocation can be
modified as needed.

Modifying the preallocation:
à Figure 5 ''Properties: PLC connection points and bus ports'', Page  AP-11

There are universally valid input/output macro variants that can be used for the
multi-line version.
à Chapter 2.3 ''Additional support '', Page  AP-14
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2.1 Modules 

Inserting a module

Procedure:

1. Select New... in the context menu of the page navigator.
è The "New page" dialog opens.

Fig. 4: New page

2. Add page with page type Overview (I).
3. Confirm with <OK>.
4. Select Insert > Device... – or – Insert > Window macro... via the menu bar

and select the macro.
In the case of large macros, the total configuration is divided into 2 variants
and can only be pasted onto 2 separate pages.

5. Confirm with <Open>.
6. Check the module in the PLC Navigator for completeness.
7. At Module is placed on rack ID enter the station number (StationNb).
8. At Position (slot / module) enter the module number (CardNumber).

Further information

For station number and the module number, see chapter "Configure hardware
module" under Developing (with SolutionCenter) in User Manual M-BASE.

Setting selectable connections

The selectable PLC connections and/or the analog inputs/analog outputs with sev-
eral connection possibilities are preallocated according to the default function defi-
nition. With these connections, the logic (analog or digital, input or output) must be
set on the function template as appropriate. For modules with 2 connections per
channel, one of both preallocated connections is deactivated, e.g. for the AIO288.
The preallocation can be modified as needed.

Drawing with Bachmann macros
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Procedure:

1. Select Properties... in the context menu of the PLC connection in the PLC
Navigator.
è The "Properties" dialog opens.

Fig. 5: Properties: PLC connection points and bus ports
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2. Click on  next to the Function definition field.
è The "Function definitions" dialog opens.

Fig. 6: Function definitions

3. Select connection.
4. Confirm with <OK>.

Drawing with Bachmann macros
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2.2 Visualization devices 

These components are mostly customer-specific. The macros therefore contain
only the standard interfaces.

• There are always 2 variants: variant A is the connection variant, and variant B
is the display variant.

• IPM is a special type of cabinet PC: It has several variants of the mounting
macro, as this can be installed vertically or horizontally.

• Accessories must be dealt with separately, e.g. plug-in module cards.
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2.3 Additional support 

Macro variants

The following connection macros ("multi-line") for various modules are also availa-
ble:

• Current input

• Voltage input

• Resistance input

• Pt100 input

• Digital input, 3-wire connection

• Digital input, 3-wire connection with external power supply connections,
e.g. VP200 terminal block module

• Digital output, 2-wire connection

• Incremental encoder

Special feature with the incremental encoder macro

Macros of incremental encoder modules, e.g. CNT204/H, include only one connec-
tion per incremental encoder input because they are treated as a single analog
input. For the representation of an incremental encoder connection, either a stand-
ard PLC symbol for a one pin version or the Incremental Encoder macro variant
can be used. With the macro, the connections are defined as device connections,
apart from the A+ input, which with can be combined via Assign with an PLC ana-
log input.

Drawing with Bachmann macros
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Part variants

Macros with altered I/O assignment can be saved as part variants.

With configurable parts (IPC, etc.), we recommend the generation of a separate
part variant for each application. In this case, it must be ensured that the function
template with PLC parts is correct.

Generating part variants

Procedure:

1. Select Properties... in the context menu of the PLC box in the PLC Naviga-
tor.
è The "Properties" dialog opens.

Fig. 7: Properties: PLC box

2. Open "Parts" tab.
3. In the right Property field, change the Part variant to a new value.
4. Confirm with <OK>.
5. Select Generate part in the overview page context menu.
6. Confirm with <OK>.
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3 PLC addressing 

The absolute addressing of devices in M-PLC includes the module and channel
numbers and is only required for a compliant representation of the device (station
number, module number and channel number) in EPLAN Electric P8.
A separate addressing scheme must be created or imported for a compliant
addressing type between M-PLC and EPLAN.
à Chapter 1.4 ''Importing the PLC addressing scheme '', Page  AP-7

The automatic addressing of EPLAN does not function correctly when a new mod-
ule or macro is inserted, since the module number (Position (slot / module)) can
only be changed after the insertion.

Both with the EPLAN addressing tool and also for the data export, the addressing
in the Properties dialog window works with the following properties of the PLC box
and PLC connection point:

• Module is placed on rack ID

• Position (slot / module)

• Channel designation

A unique device ID is also required for the data export to the SolutionCenter.
The function text is required for further processing as a variable name in the Solu-
tionCenter. In order for it to be passed on to the SolutionCenter, the function text
must not contain any special characters or spaces.

If the absolute addressing is to be consistent with the addressing in M-PLC, the fol-
lowing should be noted:

• The module number (Position (slot / module)) can be freely assigned, how-
ever no number can be repeated. It must, however, be consistent with the PLC
configuration (CardNumber) in the SolutionCenter.

• Not all devices have their channels numbered in ascending order according to
the terminals. The EPLAN addressing that is called via Project data > PLC >
Address... can therefore only be executed with the imported addressing
scheme.
à Chapter 1.4 ''Importing the PLC addressing scheme '', Page  AP-7

• The addresses generated when a macro is inserted in EPLAN Electric P8 must
be corrected (see note above).
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3.1 Addressing with an addressing scheme 

Procedure:

1. In the PLC Navigator (Project data > PLC > Navigator) select the PLC cards
to be addressed.

2. Select Project data > PLC > Address....
è The "Readdress PLC connection points" dialog opens.

Fig. 8: "Readdress PLC connection points" dialog

3. At PLC specific settings select the imported "Bachmann M1" configuration or
a user-specific configuration (à Chapter 1.4, Page  AP-7).

4. Confirm with <OK>.

PLC addressing
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3.2 Implementing external automatic addressing 

The external automatic addressing generates the address from the module number
(Position (slot / module)) and the channel number.
The formula for calculating the address is stored in the Microsoft Excel® file
Template_PLC_Addressing_de_en.xls.
Example: Channel 5 of an analog input module with the module number 36 is given
the calculated address IW36.5.

Requirements

• The Module is placed on rack ID and Position (slot / module) fields
must be filled in at the Properties of every device.
Module is placed on rack ID corresponds to the MConfig.ini keyword
StationNb.
Position (slot / module) corresponds to the MConfig.ini keyword Card-
Number.

• The Microsoft Excel® template Template_PLC_Addressing_de_en.xls for
export is preferably filed in the direc-
tory ..\EPLAN\Electric P8\Templates\<CustomerID>.

• The PLC_Addressing_Filter (PCfiP.PLC_Addressing_Filter) filter
scheme must be available in the PLC Navigator.
à Chapter 1.2 ''Importing the filter scheme '', Page  AP-5

• The export scheme PLC_Addressing_Schema
(PCfiP.PLC_Addressing_Schema) must be available at Utilities > Edit
properties externally > Export functions.
à Chapter 1.3 ''Importing the export scheme '', Page  AP-6

Procedure:

1. Select the filter scheme PLC_Addressing_Filter in the PLC Navigator and
activate the check box Active.

2. Highlight the external addressing components in the PLC Navigator.
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3. Select Utilities > Edit properties externally > Export functions via the
menu bar.
è The "Edit functions externally" dialog opens.

Fig. 9: Edit functions externally

4. Select the PLC_Addressing_Schema export scheme.
5. Select the language.
6. Select Edit in external application and reload as output type.
7. Confirm with <OK>.

è Microsoft Excel® is opened.

In order for the external addressing to function correctly, the security
level of the macros must be set in Microsoft Excel® to Medium.

8. Confirm the security warning with <Acivate macros> macros.

The Microsoft Excel® template contains the formula for calculating
the absolute addresses. The Function text column can be reworked
and filled in.

9.
In Microsoft Excel® click on , so that PLC
addresses are generated automatically and the program is closed.
è Import to EPLAN Electric P8 is started.

10. Confirm data import with <Yes>.
11. Select Utilities > Synchronize > Functions > Overview --> All

representation types via the menu bar so that the PLC data is synchronized
from Overview to Multi-line.

12. Check PLC addresses.

PLC addressing
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4 SolutionCenter data transfer 

Performing a SolutionCenter export

Requirements

• The Module is placed on rack ID and Position (slot / module) fields
must be filled in at the Properties of every device.
Module is placed on rack ID corresponds to the MConfig.ini keyword
StationNb.
Position (slot / module) corresponds to the MConfig.ini keyword Card-
Number.

• The PLC_Addressing_Filter (PCfiP.PLC_Addressing_Filter) filter
scheme must be available in the PLC Navigator.
à Chapter 1.2 ''Importing the filter scheme '', Page  AP-5

• The export scheme PLC_Addressing_Schema
(PCfiP.PLC_Addressing_Schema) must be available at Utilities > Edit
properties externally > Export functions.
à Chapter 1.3 ''Importing the export scheme '', Page  AP-6

• The PLC configuration must be completed in the schematic project and
verified. However, it is possible to make changes to the configuration.

Procedure:

1. Select the filter scheme PLC_Addressing_Filter in the PLC Navigator and
activate the check box Active.

2. Highlight the export components in the PLC Navigator.
3. Select Utilities > Edit properties externally > Export functions via the

menu bar.
è The "Edit functions externally" dialog opens.

Fig. 10: Edit functions externally

4. Select the PLC_Addressing_Schema export scheme.
5. Select the language.
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6. Select Export and start application as output type.
7. Confirm with <OK>.

è Microsoft Excel® is opened.

In order for the creation of the EDC file to function correctly, the
security level of the macros must be set to Medium in Microsoft
Excel®.

8. Confirm the security warning with <Activate macros>.
9.

In Microsoft Excel® click on , so that an EDC file
is generated automatically and the program is closed.
è The dialog "Export EDC file" is opened.

Fig. 11: "Export EDC file" dialog

The "Export EDC file" dialog always shows the last file used.

10. Define export target and file name:

Create a new EDC file
10.1 At Folder use the <Select folder> button to select the folder in which

the EDC file is to be stored.
The export target can also be entered manually in the Folder entry
field.

10.2 Enter the file name in the File entry field.

EDC file already exists
10.3 Select the EDC file via the <Select folder & file> button.

The export target and the file name can also be entered manually in
the entry field.

11. Confirm with <OK>.
è EDC file is exported.

Microsoft Excel® is automatically closed.

For further information on importing an EDC file in the SolutionCenter see chapter
"Import ECAD data" at Developing (with SolutionCenter) in the User Manual M-
BASE.

SolutionCenter data transfer
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